首页 编程开发正文

Centos /lib64/libc.so.6: version `GLIBC_2.28‘ not found (required by...) Go 项目

文章目录
  1. 问题背景
  2. 解决方案
  3. 报错1
  4. 报错2

问题背景

本文向大家介绍centos系统在启动一些服务的时候会碰到的/lib64/libc.so.6: version `GLIBC_2.28’ not found (required by…的问题的解决方法,根据提示可知碰到此问题,是因为没有找到GLIBC_2.28版本,需要添加GLIBC的2.28版本

我是安装mindoc,用go 开发的项目,但是配置后提示上述错误

解决方案

cd /usr/local/
wget https://mirror.bjtu.edu.cn/gnu/libc/glibc-2.28.tar.xz --no-check-certificate
tar -xf glibc-2.28.tar.xz
cd glibc-2.28/
mkdir build
cd build/
../configure --prefix=/usr/local/glibc-2.28

运行该命令后会报下面两个错误


报错1

configure: error: in `/root/test/glibc-2.28/build’:
configure: error: no acceptable C compiler found in $PATH

先执行

yum install gcc

之后再执行

../configure --prefix=/usr/local/glibc-2.28

会遇到报错2

报错2

These critical programs are missing or too old: make bison compiler
Check the INSTALL file for required versions.

make bison compiler太过老旧

解决:

升级GCC编译器


yum -y install Centos-release-scl
yum -y install devtoolset-8-gcc devtoolset-8-gcc-c++ devtoolset-8-binutils
scl enable devtoolset-8 bash
echo "source /opt/rh/devtoolset-8/enable" >>/etc/profile


升级make


wget http://ftp.gnu.org/gnu/make/make-4.2.tar.gz
tar -xzvf make-4.2.tar.gz
cd make-4.2
sudo ./configure
sudo make
sudo make install
sudo rm -rf /usr/bin/make
sudo cp ./make /usr/bin/
make -v


再次回到GLIBC目录


cd /usr/local/glibc-2.28/build/
yum install -y bison
sudo ../configure --prefix=/usr --disable-profile --enable-add-ons --with-headers=/usr/include --with-binutils=/usr/bin
make  //make 运行时间较长
make install


验证GLIBC是否存在GLIBC-2.28版本


[root@centos-dm ~]# strings /lib64/libc.so.6 |grep GLIBC
GLIBC_2.2.5
GLIBC_2.2.6
GLIBC_2.3
GLIBC_2.3.2
GLIBC_2.3.3
GLIBC_2.3.4
GLIBC_2.4
GLIBC_2.5
GLIBC_2.6
GLIBC_2.7
GLIBC_2.8
GLIBC_2.9
GLIBC_2.10
GLIBC_2.11
GLIBC_2.12
GLIBC_2.13
GLIBC_2.14
GLIBC_2.15
GLIBC_2.16
GLIBC_2.17
GLIBC_2.18
GLIBC_2.22
GLIBC_2.23
GLIBC_2.24
GLIBC_2.25
GLIBC_2.26
GLIBC_2.27
GLIBC_2.28
GLIBC_PRIVATE


版权声明

本文仅代表作者观点,不代表本站立场。
本文系作者授权发表,未经许可,不得转载。

评论