首页 编程开发正文

易语言取HTTP状态码,可获取301/302跳转地址

摘再网络,代码不错,希望能帮助到需要的人。

.版本 2

.支持库 spec


.子程序 取状态, 整数型

.参数 url, 文本型

.局部变量 http, 对象

.局部变量 p, 变体型


.如果真 (http.创建 (“WinHttp.WinHttpRequest.5.1”, ))

    http.写属性 (“Option”, 6, 0)

    http.方法 (“SetTimeouts”, 5000, 5000, 10000, 5000)

    http.方法 (“open”, “GET”, url, 假)

    http.方法 (“setRequestHeader”, “User-Agent”, “Mozilla/4.0 (compatible; MSIE 6.0; windows NT 5.1; SV1)”)

    http.方法 (“setRequestHeader”, “Accept-Language”, “zh-cn”)

    http.方法 (“setRequestHeader”, “Connection”, “Keep-Alive”)

    http.方法 (“setRequestHeader”, “Accept”, “image/gif, image/x-xbitmap, image/jpeg, image/pjpeg, application/x-shockwave-flash, application/x-silverlight, */*”) 

    http.方法 (“send”, )

    p = http.读属性 (“status”, )

    调试输出 (p.取数值 ())

    返回 (p.取数值 ())

.如果真结束

返回 (0)


.子程序 取跳转地址, 文本型

.参数 url, 文本型

.局部变量 http, 对象

.局部变量 p, 变体型


.如果真 (http.创建 (“WinHttp.WinHttpRequest.5.1”, ))

    http.写属性 (“Option”, 6, 0)

    http.方法 (“SetTimeouts”, 5000, 5000, 10000, 5000)

    http.方法 (“open”, “GET”, url, 假)

    http.方法 (“setRequestHeader”, “User-Agent”, “Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)”)

    http.方法 (“setRequestHeader”, “Accept-Language”, “zh-cn”)

    http.方法 (“setRequestHeader”, “Connection”, “Keep-Alive”)

    http.方法 (“setRequestHeader”, “Accept”, “image/gif, image/x-xbitmap, image/jpeg, image/pjpeg, application/x-shockwave-flash, application/x-silverlight, */*”) 

    http.方法 (“send”, )

    p = http.读属性 (“GetResponseHeader”, “Location”)

    调试输出 (p.取文本 ())

    返回 (p.取文本 ())

.如果真结束

返回 (“”)


版权声明

本文仅代表作者观点,不代表本站立场。
本文系作者授权发表,未经许可,不得转载。

评论